User Tools

Site Tools


salt-stack:minion_modules

Additional packages for Minion modules

Documentation
Name: Additional settings for Minion moudules
Description: Completing CentOS installation to run some minion modules
Modification date :20/05/2019
Owner:dodger@ciberterminal.net
Notify changes to: sysadmin
Tags:


I've set the log level to trace and I still can't see the error :-(
I'm done with this cause all the github issues from saltstack repo indicate a bug on the minion side…

Minion modules not available

This document cover some modules that can't be loaded by default:

2019-05-20 08:58:45,764 [salt.minion      ][INFO    ][13233] Starting a new job with PID 13233
2019-05-20 08:58:45,903 [salt.loader      ][DEBUG   ][13233] Error loading module.tls: ['PyOpenSSL version 0.10 or later must be installed before this module can be used.']
2019-05-20 08:58:45,904 [salt.loader      ][DEBUG   ][13233] Error loading module.glusterfs: glusterfs server is not installed
2019-05-20 08:58:45,934 [salt.loader      ][DEBUG   ][13233] Error loading module.nacl: libnacl import error, perhaps missing python libnacl package
2019-05-20 08:58:46,056 [salt.loader      ][DEBUG   ][13233] Error loading module.ipmi: No module named pyghmi.ipmi
2019-05-20 08:58:46,059 [salt.loader      ][DEBUG   ][13233] Error loading module.npm: npm execution module could not be loaded because the npm binary could not be located
2019-05-20 08:58:46,082 [salt.utils.lazy  ][DEBUG   ][13233] Could not LazyLoad pkg.update
2019-05-20 08:58:46,082 [salt.minion      ][DEBUG   ][13233] Minion return retry timer set to 10 seconds (randomized)

NaCl module

Official NaCl web.

yum -y install nacl nacl-devel libffi-devel python-devel
easy_install pynacl

And still:

2019-05-20 09:30:05,468 [salt.loader      ][DEBUG   ][62216] Error loading module.nacl: libnacl import error, perhaps missing python libnacl package

TLS module

yum install pyOpenSSL

but:

2019-05-20 09:30:05,436 [salt.loaded.int.module.tls][ERROR   ][62216] You should upgrade pyOpenSSL to at least 0.14.1 to enable the use of X509 extensions

Cause:

avmlp-pmta-001 /etc/salt # rpm -qi pyOpenSSL
Name        : pyOpenSSL
Version     : 0.13.1
Release     : 4.el7
Architecture: x86_64
Install Date: Mon 20 May 2019 09:29:58 AM CEST
Group       : Development/Libraries
Size        : 645496
License     : ASL 2.0
Signature   : RSA/SHA256, Mon 12 Nov 2018 03:44:47 PM CET, Key ID 24c6a8a7f4a80eb5
Source RPM  : pyOpenSSL-0.13.1-4.el7.src.rpm
Build Date  : Tue 30 Oct 2018 05:46:41 PM CET
Build Host  : x86-01.bsys.centos.org
Relocations : (not relocatable)
Packager    : CentOS BuildSystem <http://bugs.centos.org>
Vendor      : CentOS
URL         : http://pyopenssl.sourceforge.net/
Summary     : Python wrapper module around the OpenSSL library
Description :
High-level wrapper around a subset of the OpenSSL library, includes among others
 * SSL.Connection objects, wrapping the methods of Python's portable
   sockets
 * Callbacks written in Python
 * Extensive error-handling mechanism, mirroring OpenSSL's error codes
salt-stack/minion_modules.txt · Last modified: 2019/07/18 09:19 (external edit)